Page 5 of 5 FirstFirst ... 345
Results 41 to 43 of 43

Thread: Clutch fluid leak

  1. #41
    AdminiSTrator Mellow's Avatar
    Bike
    ST-1200
    Join Date
    Dec 2004
    Location
    Carrollton, TX
    Age
    53
    Posts
    27,476
    Tip Overs
    2
    2017 Miles
    002339

    My Gallery

    Re: Clutch fluid leak

    Quote Originally Posted by 2xthefun View Post
    Thank you Mellow

    Sent from my SM-N910T using Tapatalk
    Might be a fitting or something also... you need to confirm that. Probably need to remove the plastic to get a better look.

  2. #42

    Re: Clutch fluid leak

    Thank you. I have a day off on Thursday, so I can't wait to get greasy!

    Sent from my SM-N910T using Tapatalk

  3. #43
    Site Supporter MaxPete's Avatar
    Bike
    2007 ST1300 ABS
    Join Date
    Oct 2015
    Location
    Windsor, Canada
    Posts
    947
    Tip Overs
    1
    My Gallery

    Re: Clutch fluid leak

    Hi 2x: I just saw your posted question. I would say that you clutch slave is definitely leaking.

    If you fill up the master cylinder reservoir, it will work for a while, but the level WILL drop again and eventually, you will have a puddle on the floor under the bike (see the article on "ST1300 Clutch Slave Cylinder Replacement for an explanation).

    Anyhow, it's not a fun job, but it's not expensive and it doesn't take too long if you've got the right tools (long handled ring ratchet wrenches from Snap-on and a 1/4" drive socket set. It's all covered in the article.

    Best of luck,

    Pete

    PS - Please feel free to PM me if you have any questions.
    The harder I work, the luckier I get.

+ New Posts
Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •