Page 8 of 8 FirstFirst ... 678
Results 71 to 73 of 73

Thread: ST1300 - Clutch Slave Cylinder Replacement

  1. #71
    Site Supporter
    (Threadstarter)
    MaxPete's Avatar
    Bike
    2007 ST1300 ABS
    Join Date
    Oct 2015
    Location
    Windsor, Canada
    Posts
    1,055
    Tip Overs
    1
    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Great input Marc - glad it worked out for you!

    Hey Mr. BeedleBug - how are you making out with your CSC problem in Anthem AZ? Has anyone nearby contacted you to help with the fix?

    Pete
    The harder I work, the luckier I get.

  2. #72
    Dave.David's Avatar
    Bike
    2004 ST1300A
    Join Date
    Dec 2016
    Location
    LA California USA
    Posts
    545
    2017 Miles
    003000

    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Keep me in the loop guys, I may be able to ride out and do that work for BeedleBug.

    Sent from my SAMSUNG-SM-G935A using Tapatalk

  3. The Following 2 Users Like This Post:


  4. #73
    Site Supporter
    (Threadstarter)
    MaxPete's Avatar
    Bike
    2007 ST1300 ABS
    Join Date
    Oct 2015
    Location
    Windsor, Canada
    Posts
    1,055
    Tip Overs
    1
    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Hi Dave: that would be great! I'd just PM him - I don't think he's been on the forum lately.

    Pete

+ New Posts
Page 8 of 8 FirstFirst ... 678

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •