Page 11 of 11 FirstFirst ... 91011
Results 101 to 105 of 105

Thread: ST1300 - Clutch Slave Cylinder Replacement

  1. #101

    Re: ST1300 - Clutch Slave Cylinder Replacement

    I'm on it....just sent him a PM and an Email with my number, to be used 24/7 if needed for any reason!

  2. The Following User Likes This Post:


  3. #102
    Site Supporter
    (Threadstarter)
    MaxPete's Avatar
    Bike
    2007 ST1300 ABS
    Join Date
    Oct 2015
    Location
    Windsor, Canada
    Posts
    1,221
    Tip Overs
    1
    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Thank Igofar - you’re a champ.

    Lemme know if/how I can help.

    Pete
    The harder I work, the luckier I get.

  4. The Following User Likes This Post:


  5. #103

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Maybe we can get someone to order a motion pro bleeder on amazon and have it dropped shipped to him.

  6. The Following User Likes This Post:


  7. #104
    Site Supporter
    (Threadstarter)
    MaxPete's Avatar
    Bike
    2007 ST1300 ABS
    Join Date
    Oct 2015
    Location
    Windsor, Canada
    Posts
    1,221
    Tip Overs
    1
    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    I’ll contribute to the cost if anyone would take the lead on that.

    Pete

  8. #105
    SoCal Lane Splitting Commuter SupraSabre's Avatar
    Bike
    12/10/04/04 ST 1300s
    Join Date
    Nov 2005
    Location
    Murrieta, CA
    Posts
    9,375
    Tip Overs
    001
    2018 Miles
    004295

    My Gallery

    Re: ST1300 - Clutch Slave Cylinder Replacement

    Quote Originally Posted by SupraSabre View Post
    I'm not done yet... This weekend!
    I did finish the 2010, but the clutch is still slipping. And now with the '04#2 not starting, I'll try to replace the clutch and waterpump on the 2010 ASAP!
    Bob - STOC 5901
    2012 ST1300 -17,500 miles, 2010 - 65,000 miles , 2006 -Basketcase
    2004 ST1300 X2/#1 - 37,000 -needs waterpump & #2 35,000 miles (on the road again)
    2005 ST1300 - 174,300 miles - sold

  9. The Following User Likes This Post:


+ New Posts
Page 11 of 11 FirstFirst ... 91011

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •