Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: Replacing OEM Taillight Bulbs w/LED's

  1. #41
    (Threadstarter)
    st11ray's Avatar
    Bike
    '06 ST1300
    Join Date
    Jul 2007
    Location
    charlotte, nc
    Age
    57
    Posts
    2,808
    My Gallery

    Re: Replacing OEM Taillight Bulbs w/LED's

    Quote Originally Posted by Bazza99 View Post
    Hi and thanks for the info.

    I am in the process of turning my ST1300 Police project bike into total LED. I recently purchased some rear turn signal LED's but have found that they are slightly longer (60mm) than the allowed space. Can you advise which set you used for the turn signals, and also, is it better to use white behind amber lens or yellow behind amber? I have installed LED headlight, and switchback running lights at the front along with 'flashing' LED's for stop/tail. Very please with the effect so far.

    Appreciate any feedback.
    Here are the bulbs I put in the back.

    http://www.jdmastar.com/product/170/...-Set-of-2.html

    http://www.jdmastar.com/product/85/P...-Set-of-2.html
    '06 ST1300
    Easternbeaver PC8, MCL Fuse Box Mount, Stebel Horn, Auxbeam 60 watt 5" LED lights w/ Dick Seng Mounts, Whelen B/T/T Strip Light, Hyperlites, Givi E460 Top Box, Throttlemeister, Tailbrights, Bike Quip Flip Top Tinted Windscreen, V4 Badges, BMW Grips

  2. #42
    240Robert ST Gui's Avatar
    Bike
    ST1300, 2010
    Join Date
    Sep 2011
    Location
    SF-Oakland CA
    Posts
    4,738
    My Gallery

    Re: Replacing OEM Taillight Bulbs w/LED's

    Quote Originally Posted by st11ray View Post
    Here are the bulbs I put in the back.
    Your two links give a 404 return.
    Don't tell me what I know. Tell me what I don't know.

    Ride safe, ride often.

  3. #43
    (Threadstarter)
    st11ray's Avatar
    Bike
    '06 ST1300
    Join Date
    Jul 2007
    Location
    charlotte, nc
    Age
    57
    Posts
    2,808
    My Gallery

    Re: Replacing OEM Taillight Bulbs w/LED's

    Quote Originally Posted by ST Gui View Post
    Your two links give a 404 return.
    Yeah, I copied and pasted them from post #10. Go back to post 10 and the links work.

  4. #44
    ddemair's Avatar
    Bike
    2010 Honda ST13
    Join Date
    Feb 2012
    Location
    central NJ
    Posts
    508
    Tip Overs
    2
    My Gallery

    Re: Replacing OEM Taillight Bulbs w/LED's

    Here's a link to a post I made regarding flashing brake lights:

    http://www.st-owners.com/forums/show...=1#post2015445

+ New Posts
Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •